deepcloud - Delays sending emails – Incident details

All systems operational

Delays sending emails

Resolved
Degraded performance
Started 18 days agoLasted about 7 hours

Affected

DeepCloud Services

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

DeepBox

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

DeepSign

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

DeepID

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

DeepO

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

DeepValidator

Degraded performance from 8:00 AM to 1:30 PM, Operational from 1:30 PM to 3:00 PM

Updates
  • Resolved
    UTC
    Resolved

    This incident has been resolved on Microsoft's side, and all emails in the queue should now have been delivered.

  • Monitoring
    UTC
    Monitoring

    The number of temporary rejections has dropped significantly. We were informed that queues are now decreasing across all services and data centres, and email delivery is returning to normal.

  • Identified
    UTC
    Identified

    We're currently seeing intermittent delays sending emails to Microsoft-hosted addresses. Microsoft's mail servers are temporarily rejecting some messages and asking us to retry later, which can cause emails to arrive later than usual.